ubuntu和最新centos如何安装node.js

yoka   ·   发表于 6个月前   ·   云计算应用

这里要说得的是,如果要安装18.10.0以上版本的node.js对linux操作系统是有要求的。

一般来说ubuntu需要Ubuntu 20.04.3以上操作系统,linux操作系统需要8.0以上的。


这里给出了通用安装命令供参考:(node.js版本是v18.19.0)

yum install -y wget      # 支持链接下载


yum -y install git         # 支持git链接下载


wget https://nodejs.org/download/release/latest-v18.x/node-v18.19.0-linux-x64.tar.xz     # 链接下载node.js官方版本


xz -d node-v18.19.0-linux-x64.tar.xz    # 解压文件

tar -xf node-v18.19.0-linux-x64.tar      # 解压文件


mv node-v18.19.0-linux-x64/ /usr/local/    # 移动文件到新的目录


vi /etc/profile     # 编辑profile


export NODEJS=/usr/local/node-v18.19.0-linux-x64       # 添加环境规则

export PATH=$PATH:$NODEJS/bin


source /etc/profile     #刷新profile服务


ln -s /usr/local/node-v18.19.0-linux-x64/bin/node /usr/bin      # 建立node软链接

ln -s /usr/local/node-v18.19.0-linux-x64/bin/npm /usr/bin    # 建立npm 软链接


node -v     # 检测版本号,是否安装正常

npm -v     # 检测版本号,是否安装正常

打赏我,让我更有动力~

0 Reply   |  Until 6个月前 | 842 View
LoginCan Publish Content
每日签到
连续签到0天